科技网

当前位置: 首页 >通讯

更安全升级AndroidQ后低级别App不能再运行

通讯
来源: 作者: 2019-04-09 05:28:33

【网手机频道】如今手机已成为我们生活当中不可分割的一部分,各种App在其中扮演了重要角色。为了获取更多的利益,许多App假借向用户提供更好的服务为借口,超出手机系统,直接获取手机权限,收集用户信息等隐私。一时间,手机安全方面成为了用户与厂商头疼的问题。

在前几日,素以安全著称的苹果iOS系统,也被安全问题弄得头大,被迫做出重大调剂:所有的iOS应用软件都要具有一个用户隐私保护协议,并且禁止手机软件获取不相关的权限和数据,以此来最大限度的保护用户利益。

在这份公告中,苹果明确指出,将从今年10月3日开始,所有提交到苹果AppStore和TestFlight(苹果下属的手机软件测试服务)的新App以及升级版本,都必须具备完整的用户隐私保护协议。

而今天,谷歌也开始行动起来。据XDA报导,依照谷歌的命名习惯,下一代安卓系统会是AndroidQ(依照字母表排序),版本号或将为Android10。并且在AOSP中出现了面向第一代安卓系统的贡献代码,其中包括一项系统级的警告特性。在运行任何应用程序时,系统都会检查其API级别,如果低于或等于23(安卓5.0棒棒糖或更老),则会弹出警告,提示可能没法正常运行。

资料显示,从今年8月1日起,所有新向Play商店提交的应用都必须基于APILevel26(安卓8.0及以上)开发,同时,今年11月后,所有Play商店的存量运用也都要遵照这1规定,否则予以下架。谷歌此举首先是保证良好的兼容性,同时,API等级越高,也可以同步谷歌在安全性、隐私性、内存优化、电池优化的最新改善。

由于此前的安卓系统安全漏洞比较多,同时一些开发者不愿意使用安卓6.0版本及以上的配套API,导致低版本的安卓系统成为了流氓软件的群居之地。根据今年5月安兔兔发布的数据显示,目前安卓8.1系统的用户最多,其占比为17.22%。不过仍有20%左右的用户还在使用API级别低于或等于23(安卓5.0棒棒糖或更老)的系统版本,这也突显了提升安全等级的必要性。

除此之外,谷歌在不久前还采取了一个强制性措施——提出“防回滚”机制。据了解,谷歌在安卓8.0系统中内置了名为“回滚保护”的安全功能,该功能会阻挠设备回退到旧版本的固件。如果强制刷机的话,手机会直接变砖,无法修复。谷歌还介绍道,之所以在安卓8.0系统中内置“回滚保护”功能主要是出于对用户数据信息安全方面的综合考虑,毕竟在旧版本的安卓系统固件中极有可能存在安全漏洞。

(作者:stenpan责任编辑:潘宇)新媒体最酷科技资讯扫码赢大奖

安阳哪家医院治疗男科好
治疗闭经哪家医院好
面部白癜风如何能够治好

相关推荐